Public form short-links failing
Incident Report for Broadstripes
Resolved
AWS has restored the mechanism that we use to translate short links for public forms, and so the service is functional again.

We apologize for any inconvenience.
Posted Jun 13, 2023 - 20:38 UTC
Investigating
Amazon Web Services seems to be having problems at the data center that hosts Broadstripes.

So far, this is affecting only public forms accessed via short-link. We are notifying AWS of the issue, though they are certainly aware of the larger-scale problem.

We will update with any more information we learn or when the problem is resolved.
Posted Jun 13, 2023 - 19:18 UTC
This incident affected: Application services (Public forms).